Este mensaje lo da el ERP cuando se conecta a la base de datos que no tiene aplicado el Hotfix o que no tiene actualizada la versión del (.exe) del ERP. Este mensaje lo van a mejorar desde fábrica en próximos hotfixes.



En este caso nos dice que la versión de  BBDD si tiene el Hotfix, pero el ERP tiene una versión anterior. Se ha de reinstalar ERP, ADMON y resto de productos como TPV, SERVICIO, API si los hay.

Para poder saber si el hotfix ha sido aplicado en BBDD consultamos por base de datos la tabla "Actualizador_Hotfixes" y si vemos que este no existe, hay que aplicarlo. Esta tabla contiene un registro de los hotfixes que han sido aplicados. Si se aplica dos veces, no afectaría a nada,  añadiría otro registro.

 

Recuerda:

La actualización de Base de datos, sólo se realiza entre versiones (ej. 4.4.2100 a 4.4.2xx), no entre diferentes Hotfixes (ej. 4.4.2100.9 a 4.4.2100.10) de la misma versión. La actualización de las librerías de la base de datos es necesaria siempre que se vaya a cambiar de una versión anterior a una versión superior, si aplicamos un Hotfix deberemos cambiar las librerías para que, al pasar entre versiones, no se actualice a unas librerías incompatibles con el hotfix.